Finding Latest software for SOLIX

When updating Humminbird units, in most cases you can update straight to the latest version available. However, over the years there have been a few firmware versions that are necessary to have installed before proceeding to anything more recent. This is primarily found in the SOLIX series.

Below we will list these required versions of software and any applicable information or instructions that go with them.

Software Version 3.040

  • Only applies to SOLIX G1
  • File name: solix-unified-app-r3.040.upd
  • Version 3.040 is the first required update and must be installed prior to installing versions 3.350* or 3.500. 
  • The 3.040 software file is available in the same folder when downloading version 3.350* or 3.500. See image below:
    mceclip1.png
    *Note: Software version 3.350 is only needed when networking SOLIX G1 with ONIX units. If this is not the case, then this update (3.350) can be skipped entirely.

Software Version 3.500

  • Only applies to SOLIX G1/G2
  • File name: solix-unified-app-r3.500.upd
  • Version 3.500 must be installed prior to installing any version higher
  • The 3.500 file can be downloaded on the current software update page.

Software Version 3.900

  • Only applies to SOLIX G3
  • File name: solix-update-r3.900.upd
  • Version 3.900 must be installed prior to installing any version higher
  • The 3.900 file can be downloaded on the current software update page.
Was this article helpful?
0 out of 0 found this helpful