Can I load multiple versions of software to my card when updating my Humminbird APEX or SOLIX?

Updating the software on APEX, SOLIX and ONIX sometimes requires a prerequisite version be installed first. For example, on SOLIX G1 and G2 models, software version 3.500 must be installed prior to anything later.

These units must be updated in the proper order as instructed, or else the update will always fail.

When needing to install multiple updates on your APEX, SOLIX or ONIX it can be very convenient to load all files needed to the SD or MicroSD card at one time.

This is fine! However, when multiple update files for the same unit are present on the card, the unit will automatically try to load the most recent software version and a prompt will appear on screen. When this happens, perform the following:

  1. You must choose Cancel on the prompt.
    mceclip0.png
  2. After hitting cancel, you will need to press the HOME key and tap on the Files widget.
    mceclip1.png
    • If the Files widget is not visible on the home screen, select All Tools at the bottom of the Home page.
      mceclip4.png
  3. Select the file needed and then choose Install Now.
    mceclip5.png
  4. Repeat the steps above as necessary.
  •  
Was this article helpful?
1 out of 2 found this helpful